‍Reparatur ‍M8310 ‍Major ‍Registers ‍Control


‍Diese ‍Platine ‍gehört ‍zu ‍einem ‍Satz ‍von ‍PDP8/e ‍Karten, ‍die ‍ich ‍mir ‍freundlicherweise ‍ausleihen ‍durfte.

‍Denn ‍als ‍meine ‍LAB8/e ‍noch ‍defekt ‍war, ‍half ‍das ‍beim ‍Eingrenzen ‍des ‍Fehlers. ‍Es ‍stellte ‍sich ‍dann ‍heraus, ‍daß ‍M8310 ‍von ‍diesen ‍Karten ‍selbst ‍defekt ‍war. ‍Also ‍wollte ‍ich ‍es ‍gerne ‍hinbekommen ‍sie ‍zu ‍reparieren.

‍Der ‍Defekt ‍liess ‍es ‍nicht ‍zu ‍Programme ‍zu ‍laden. ‍Somit ‍musste ‍ohne ‍die ‍MAINDEC ‍Testprogramme ‍gearbeitet ‍werden.

‍Nach ‍einigem ‍Ausprobieren ‍mit ‍kleinen ‍Code ‍Sequenzen ‍mit ‍den ‍Frontschaltern, ‍stellte ‍sich ‍heraus, ‍es ‍gab ‍Probleme ‍mit ‍den ‍Befehlen: ‍RAR, ‍RTR, ‍RAL, ‍RTL ‍UND ‍GLK. ‍Es ‍sah ‍so ‍aus, ‍als ‍würde ‍ein ‍gesetztes ‍Link ‍verloren ‍gehen ‍beim ‍Rotieren. ‍Durch ‍Blick ‍in ‍das ‍„PDP8-e ‍Maintenance ‍Manual ‍Vol1“ ‍von ‍Dezember ‍1972, ‍wird ‍in ‍Kapitel ‍3.39 ‍die ‍Link ‍Logik ‍beschrieben.

‍Speziell ‍Seite ‍3-142 ‍war ‍hilfreich. ‍Dazu ‍wird ‍noch ‍der ‍Schaltplan ‍zur ‍M8310 ‍aus ‍den ‍„Engeneering ‍Drawings“ ‍benötigt.

‍Die ‍Link ‍Lampe ‍geht ‍an ‍und ‍aus, ‍wenn ‍der ‍Link ‍gesetzt ‍ist ‍oder ‍nicht. ‍Invertieren ‍klappt. ‍Das ‍Signal ‍AV2 ‍ist ‍also ‍im ‍Omnibus ‍korrekt.

‍Zuerst ‍habe ‍ich ‍den ‍„LINK“ ‍im ‍Schaltplan ‍lokalisiert. ‍Dann ‍habe ‍ich ‍versucht ‍mögliche ‍IC ‍Kandidaten ‍zu ‍finden, ‍die ‍im ‍LINK ‍wichtige ‍Treiber ‍Funktionen ‍haben. ‍Die ‍aber ‍nicht ‍mit ‍dem ‍AV2 ‍Signal ‍in ‍Verbindung ‍stehen. ‍In ‍der ‍Hoffnung ‍diese ‍haben ‍einen ‍Schaden, ‍wurden ‍ohne ‍lange ‍Messungen ‍proaktiv ‍folgende ‍IC’s ‍gewechselt:

‍E2 ‍(DEC ‍8881)

‍E43 ‍(DEC ‍8881)

‍E23 ‍(DEC ‍8881) ‍zum ‍Link ‍Multiplexer

‍E33 ‍(SN ‍7474) ‍hatte ‍gelesen, ‍die ‍gehen ‍sehr ‍oft ‍kaputt

‍E24 ‍(SN ‍74151) ‍Link ‍Multiplexer

‍Leider ‍ohne ‍Erfolg. ‍

‍Dann ‍habe ‍ich ‍mir ‍den ‍Text ‍noch ‍einmal ‍genauer ‍durchgelesen. ‍Und ‍meine ‍verstanden ‍zu ‍haben, ‍der ‍Fehler ‍muß ‍aus ‍dem ‍„Link ‍Gating ‍Network“ ‍von ‍E23+E32+E37+E38 ‍herrühren.

‍Denn ‍der ‍„Link ‍Multiplexer“ ‍hat ‍nur ‍deinen ‍Eingang ‍über ‍E23 ‍(Ad ‍Link ‍L), ‍sonst ‍Ausgänge ‍zum ‍AC ‍Multiplexer. ‍Das ‍erste ‍IC ‍von ‍den ‍vieren ‍hatte ‍ich ‍ja ‍schon ‍erfolglos ‍getauscht. ‍Erst ‍das ‍letzte ‍getauschte ‍IC ‍war ‍defekt, ‍Das ‍E37 ‍(7402).  Danach ‍funktionierte ‍alles. ‍Im ‍Verlauf ‍konnte ‍OS/8 ‍gebootet ‍werden ‍(os8diskserver) ‍und ‍die ‍Maindec ‍Instruction ‍Tests ‍1 ‍+ ‍2  durften ‍nach ‍10 ‍Minuten ‍abgebrochen ‍werden.